What are the system requirements?

Talkatoo works on both Windows and Mac OSX

The following Operating System versions are supported:

  • Windows 7 or newer, or Windows Server 2008 R2 or newer.
  •  macOS 10.14 or newer

NOTE
Currently for some versions of macOS older than 10.14, you will still able to install and launch Talkatoo, however you will NOT be able to dictate.  

 

Our product roadmap includes Android and iOS versions of Talkatoo but currently we do not have a version for iPhone, iPad, or Android.  iOS version is expected in 2022.   

At this time, there is no support for Chromebook

Hardware

CPU

Windows: Versions available for 32 and 64-bit Windows.

Mac: Versions available for both Intel and Arm-based M1 

Memory

The memory requirements for Talkatoo are minimal, however enough memory should be available on the computer for a smooth experience overall, so we require a minimum of 4Gb of ram, and recommend 8+ Gb.

Internet

Because Talkatoo is cloud-based software, a stable internet connection is required to use Talkatoo. 

For optimal performance, it should be at least 5 Mbps up and down as tested from the computer being used, with no packet loss.

 

Talkatoo uses port 443 for all communication with our servers.

Please white list the following if required:

Application: https://api.talkatoo.com

Update Server: https://nucleus.talkatoo.ai